Síguenos en...
Síguenos en Twitter Síguenos en Facebook Sigue nuestro canal YouTube
Registrarse
Compartir
+ Responder tema
Página 1 de 2 12 ÚltimoÚltimo
Resultados 1 al 10 de 15

Tema: Ayuda compilar settings.apk

  1. #1
    Avatar de jorgeladivino
    Fecha de ingreso
    10 jun, 11
    Edad
    47
    Mensajes
    16

    Ayuda compilar settings.apk

    Buenas, se que es un tema de novatos pero me estoy volviendo loco jaja

    Estoy intentando compilar la apk de ajustes que he modificado para añadir unas apks al menu de ajustes (viper4android, gravitybox y otauploader) siguiendo este tutorial
    y a la hora de compilar me salta este comando todo el rato, puede ser que me haya equivocado en alguna linea...


    ''Please make your decision:11
    Building Apk
    "An Error Occured, Please Check The Log (option 21)"
    Presione una tecla para continuar . . .
    Is this a system apk (y/n)
    Type input: N
    Aside from the signatures, would you like to copy
    over any additional files that you didn't modify
    from the original apk in order to ensure least
    # of errors (y/n)
    Type input:''


    ESE ES EL ERROR SOLUCION? GRACIAS


    [log.txt]

    --------------------------------------------------------------------------
    |08/08/2013 -- 2111,44|
    --------------------------------------------------------------------------
    java version "1.7.0_25"
    Java(TM) SE Runtime Environment (build 1.7.0_25-b17)
    Java HotSpot(TM) Client VM (build 23.25-b01, mixed mode, sharing)
    I: Checking whether sources has changed...
    I: Checking whether resources has changed...
    I: Building resources...
    C:\Users\jorge\Desktop\ApkManagerV6.1\other\..\projects\Settings.apk\res\values\public.xml:245: error: Public symbol drawable/icon declared here is not defined.
    C:\Users\jorge\Desktop\ApkManagerV6.1\other\..\projects\Settings.apk\res\values\styles.xml error: Error: No resource found that matches the given name: attr 'android:preferencePanelStyle'.
    Exception in thread "main" brut.androlib.AndrolibException: brut.androlib.AndrolibException: brut.common.BrutException: could not exec command: [aapt, p, --min-sdk-version, 17, --target-sdk-version, 17, -F, C:\Users\jorge\AppData\Local\Temp\APKTOOL3504400282210120567.tmp, -0, arsc, -I, C:\Users\jorge\apktool\framework\1.apk, -S, C:\Users\jorge\Desktop\ApkManagerV6.1\other\..\projects\Settings.apk\res, -M, C:\Users\jorge\Desktop\ApkManagerV6.1\other\..\projects\Settings.apk\AndroidManifest.xml]
    at brut.androlib.Androlib.buildResourcesFull(Androlib.java:358)
    at brut.androlib.Androlib.buildResources(Androlib.java:283)
    at brut.androlib.Androlib.build(Androlib.java:206)
    at brut.androlib.Androlib.build(Androlib.java:176)
    at brut.apktool.Main.cmdBuild(Main.java:228)
    at brut.apktool.Main.main(Main.java:79)
    Caused by: brut.androlib.AndrolibException: brut.common.BrutException: could not exec command: [aapt, p, --min-sdk-version, 17, --target-sdk-version, 17, -F, C:\Users\jorge\AppData\Local\Temp\APKTOOL3504400282210120567.tmp, -0, arsc, -I, C:\Users\jorge\apktool\framework\1.apk, -S, C:\Users\jorge\Desktop\ApkManagerV6.1\other\..\projects\Settings.apk\res, -M, C:\Users\jorge\Desktop\ApkManagerV6.1\other\..\projects\Settings.apk\AndroidManifest.xml]
    at brut.androlib.res.AndrolibResources.aaptPackage(AndrolibResources.java:357)
    at brut.androlib.Androlib.buildResourcesFull(Androlib.java:336)
    ... 5 more
    Caused by: brut.common.BrutException: could not exec command: [aapt, p, --min-sdk-version, 17, --target-sdk-version, 17, -F, C:\Users\jorge\AppData\Local\Temp\APKTOOL3504400282210120567.tmp, -0, arsc, -I, C:\Users\jorge\apktool\framework\1.apk, -S, C:\Users\jorge\Desktop\ApkManagerV6.1\other\..\projects\Settings.apk\res, -M, C:\Users\jorge\Desktop\ApkManagerV6.1\other\..\projects\Settings.apk\AndroidManifest.xml]
    at brut.util.OS.exec(OS.java:89)
    at brut.androlib.res.AndrolibResources.aaptPackage(AndrolibResources.java:355)
    ... 6 more
    El sistema no puede encontrar el archivo especificado.
    "adb" no se reconoce como un comando interno o externo,
    programa o archivo por lotes ejecutable.
    El sistema no puede encontrar la ruta especificada.

    Temas Similares en HTCSpain:
  2. Problemas para compilar/decompilar ArcCamera.apk ( FC ) - [ErosizeD]
  3. Homescreen Settings - [benalex]
  4. Problema al compilar en visual kitchen - [angelpadre]
  5. Touchflo Settings - [ELSALAO]

  6. #2

    Avatar de Franlov
    Fecha de ingreso
    15 jul, 07
    Ubicación
    Sevilla
    Edad
    34
    Mensajes
    7,844
    Caused by: brut.common.BrutException: could not exec command: [aapt, p, --min-sdk-version, 17, --target-sdk-version, 17, -F

    Actualiza el sdk de android y baja las ultimas platform-tools parece ser que pide una versión distinta a la que tienes de la utilidad aapt.

    La grandeza de un hombre reside en la mujer que tiene al lado... Y yo debo de tener mucha



  7. #3
    Avatar de jorgeladivino
    Fecha de ingreso
    10 jun, 11
    Edad
    47
    Mensajes
    16
    no tengo instalado el SDK de android, ya que con el APKMANAGER no necesito tenerlo... Que me recomiendas tu?

  8. #4

    Avatar de Franlov
    Fecha de ingreso
    15 jul, 07
    Ubicación
    Sevilla
    Edad
    34
    Mensajes
    7,844
    Bajalarlo y actualizar tu mismo el aapt y apktool copiandolo en la carpeta del apkmanager

    Eso que dices que no lo necesitas el sdk es solo hasta que te pida una version mas nueva de aapt como ahora...

    Para que version de android es?

    Cita Iniciado por jorgeladivino Ver mensaje
    no tengo instalado el SDK de android, ya que con el APKMANAGER no necesito tenerlo... Que me recomiendas tu?

    La grandeza de un hombre reside en la mujer que tiene al lado... Y yo debo de tener mucha



  9. #5
    Avatar de jorgeladivino
    Fecha de ingreso
    10 jun, 11
    Edad
    47
    Mensajes
    16
    Pues gracias ya estoy instalando la ultima version de SDK, es para un movil chino que estoy haciendo una ROM, android 4.2.2 es la rom de la que parto

  10. #6

    Avatar de Franlov
    Fecha de ingreso
    15 jul, 07
    Ubicación
    Sevilla
    Edad
    34
    Mensajes
    7,844
    Nada :D

    Para cual movil chino es?

    Saludos

    Cita Iniciado por jorgeladivino Ver mensaje
    Pues gracias ya estoy instalando la ultima version de SDK, es para un movil chino que estoy haciendo una ROM, android 4.2.2 es la rom de la que parto

    La grandeza de un hombre reside en la mujer que tiene al lado... Y yo debo de tener mucha



  11. #7
    Avatar de jorgeladivino
    Fecha de ingreso
    10 jun, 11
    Edad
    47
    Mensajes
    16
    Cita Iniciado por Franlov Ver mensaje
    Nada :D

    Para cual movil chino es?

    Saludos
    STAR S5 BUTTERFLY

    - - - Updated - - -

    Aparentemente esta todo bien instalado y correcto, tambien las API de 4.2.2 y esto sigue sin funcionar :( alguna idea?

  12. #8

    Avatar de Franlov
    Fecha de ingreso
    15 jul, 07
    Ubicación
    Sevilla
    Edad
    34
    Mensajes
    7,844
    Pasame el framework-res.apk y el settings.apk

    Cita Iniciado por jorgeladivino Ver mensaje
    STAR S5 BUTTERFLY

    - - - Updated - - -

    Aparentemente esta todo bien instalado y correcto, tambien las API de 4.2.2 y esto sigue sin funcionar :( alguna idea?

    La grandeza de un hombre reside en la mujer que tiene al lado... Y yo debo de tener mucha



  13. #9
    Emotroid Team
    Avatar de Pafcholini
    Fecha de ingreso
    07 abr, 12
    Ubicación
    Barcelona
    Mensajes
    2,741
    Cita Iniciado por jorgeladivino Ver mensaje
    STAR S5 BUTTERFLY

    - - - Updated - - -

    Aparentemente esta todo bien instalado y correcto, tambien las API de 4.2.2 y esto sigue sin funcionar :( alguna idea?
    Revisa los cambios que has hecho en los xml, si no has modificado el archivo ids que está en res/values/ids también te tira ese error.

    Enviado desde mi GT-N7100 usando Tapatalk 2
    Sígueme en Twitter: Pafcholini


    Dispositivos actuales:
    1. Samsung Galaxy Note 4 (SM-N910F)
    2. Samsung Galaxy Note 2 (N7100)

  14. #10
    Avatar de jorgeladivino
    Fecha de ingreso
    10 jun, 11
    Edad
    47
    Mensajes
    16
    Dev-Host - framework-res.apk - The Ultimate Free File Hosting / File Sharing Service - framework
    Dev-Host - Settings.apk - The Ultimate Free File Hosting / File Sharing Service - Settings

    Gracias de antemano, si me puedes decir el problema perfecto, solo estoy siguiendo el tutorial para yo fiajarme y despues probar con otros programas ;)

    - - - Updated - - -

    En el tutorial no ponia nada de ids.xml por eso no modifiqué nada, que hay que añadir concretamente?

 

 
+ Responder tema
Página 1 de 2 12 ÚltimoÚltimo

Nuestros visitantes llegarón a esta página buscando:

como entrar en Settings.apk en movil chino

an error occurred please check the log (option 21)

ajustes apk android 4.2

porque al compilar settings.apk no me deja compilar

ajustes android 4.2 apk

actualizar ajustes 4.2.2 de android apk

4.2.2 settings apk

compilar settings.apk

no se puede instalar settings.apk

editar settings.apk

metodo para compilar settings.apk

no existe apktool.yml en pc

solucion htc hotspot the temporary

ajuste.apk 4.2.2

an error occured please check the log (option 21)

settings apk android 4.2.2

no resource found android:preferencePanelStyle

android 4.2.2 settings original.apk

ajustes apk 4.2.2

ajustes android 4.2.2 apk

SEO Blog